Оригинальный текст на языке EN взят с сайта-источника. Источник ↗

Cisco has released security updates to address a critical vulnerability in its Expressway Series. This flaw, tracked as CVE-2026-76466, could allow unauthenticated remote attackers to execute arbitrary operating system commands with root privileges.

It has a CVSS v3.1 base score of 9.8 and affects vulnerable Expressway deployments configured in a cluster. The advisory was published on October 21, 2026.

The vulnerability affects the platform’s database service feature and involves persistent cookies and inadequate client certificate validation.

To successfully exploit this issue, an attacker must have network access to an affected device and possess the relevant cookies. These prerequisites are crucial when assessing potential exposure.

According to Cisco, an attacker who obtains these cookies could connect to the database service and execute specific remote procedure call (RPC) commands.

This could lead to arbitrary command execution as root on the underlying operating system, granting the attacker highly privileged control over the affected device.

The advisory also notes a failure in the clustering security configuration: client certificates are not validated when TLS Verify Mode is set to “Enabled.”

As a result, enabling this setting does not provide the expected certificate validation for the affected functionality. Cisco attributes the vulnerability to issues with persistent cookies and classifies it under CWE-798.

Even though Cisco describes the attack as unauthenticated, successful exploitation still relies on obtaining the cookies. The advisory does not specify how an attacker might acquire these cookies or identify a particular technique for cookie acquisition within the disclosed attack vector.

This vulnerability impacts both Cisco Expressway Core (Expressway-C) and Cisco Expressway Edge (Expressway-E). Both virtual deployments and physical appliances are affected when they run vulnerable software and are configured in a cluster.

The advisory does not classify every Expressway installation as vulnerable; these deployment conditions define the affected scope.

Cisco tracks the issue internally as CSCww27732 and credits Stefan Aleksic of Jane Street for reporting the vulnerability.

At the time of publication, Cisco’s Product Security Incident Response Team stated that it was unaware of any public announcements or malicious exploitation involving this flaw. This statement reflects Cisco’s awareness, not proof that exploitation has never occurred.

Cisco lists version X15.5.20 as the first fixed release for versions X15.5.3 and earlier. Customers running version X14 or earlier must migrate to a fixed release.

Cisco notes that no workarounds exist for this vulnerability and strongly recommends upgrading affected systems. These corrections are part of Cisco’s broader Expressway security hardening release for October 2026.

Before upgrading, customers should verify they have sufficient device memory and that existing hardware and software configurations remain supported. Cisco advises contacting its Technical Assistance Center or maintenance providers if upgrade compatibility is uncertain.

Stops Cyber threats before impact with 21 min faster MTTR. Integrate ANYRUN’s Sandbox in your SOC.